Привет. Вчера мой коллега решил сделать ABC-анализ продаж, и пришёл ко мне советоваться, как в Экселе посчитать нарастающую сумму продаж. Оказалось, это легко, если вы владеете некоторыми начальными знаниями:

Если нет, изучите статьи по ссылкам и продолжайте чтение данного материала. И так, нарастающая сумма – это значение для каждого элемента массива, равное сумме этого элемента и всех предыдущих.

На рисунке хорошо видно, что нарастающая сумма для пятого элемента равна сумме первых пяти значений. Для шестого – первых шести и т.д. Но как это реализовать так, чтобы не пришлось для каждой строки делать отдельную формулу вручную?

Используем принцип смешанных ссылок, когда в одной формуле применяются и постоянные и относительные ссылки. Работаем с тем же примером и делаем по пунктам:

  1. Для первого значения в ячейке C2 запишем формулу =СУММ(B2:B2). Здесь первая координата – начало диапазона суммирования, вторая – конец
  2. Поставим курсор в первую координату и нажмем F4. Формула примет вид: =СУММ($B$2:B2). Теперь первая координата «заморожена» и при копировании формулы изменяться не будет. А вторая координата будет сдвигаться вниз. То есть в ячейке C3 эта же формула примет вид: =СУММ($B$2:B3). А, например, в C6 будет =СУММ($B$2:B6)
  3. Скопируем формулу из C2 во все строки этой колонки. Получим результат, как на картинке.

Это не единственный способ расчёта нарастающей суммы, но я чаще всего пользуюсь именно им, т.к. формула наиболее очевидна.