Здравствуйте, друзья. Сегодня покажу, как найти наибольший элемент в таблице без применения сортировок и фильтрации. Это позволяет избавиться от «ручной» работы и автоматизировать задачу.

Разбираем реальный пример:

список продаж

Есть таблица с продажами товаров за период. Требуется узнать, какая позиция продавалась больше всего. Действуем:

  1. Сперва найдём максимальное количество продаж в перечне, используя функцию МАКС:

    =МАКС(B3:B21)

  2. Теперь нужно получить название товара, продажи которого мы нашли. Для начала функцией ПОИСКПОЗ определим порядковый номер максимального значения в списке:

    =ПОИСКПОЗ(F3;B3:B21;0)

    индекс найдет

  3. Зная индекс найденного товара, выведем его, используя ИНДЕКС:

    =ИНДЕКС(A3:A21;ПОИСКПОЗ(F3;B3:B21;0))

    товар найден

Готово. Теперь, если данные изменятся, удалятся или добавятся, формула сама всё пересчитает.