Здравствуйте. Как убрать ошибку #Н/Д в Экселе – такой вопрос периодически приходит в голову всем осознанным пользователям программы. Сегодня покажу один из возможных способов.

Функция записывается так: =ЕНД( выражение )

Логика функции такая же простая, как и запись. ЕНД анализирует выражение в аргументе и возвращает:

  • ИСТИНА, если в выражении ошибка #Н/Д
  • ЛОЖЬ – в любом другом случае

Обычно, функцию используют для «отлова» ошибки #Н/Д и передают управление другой функции, которая и обеспечивает условное ветвление.

Пример использования. Есть список спикеров на предстоящем мероприятии. Нас интересуют два человека, будут они читать доклад, или нет.

поиск имени в списке

Полная формула будет такой:

=ЕСЛИ(ЕНД(ВПР(E3;спикеры;1;0));»Не участвует»;»Участвует»)

Диапазону A3:B17 я присвоил имя «спикеры», чтобы формула стала проще и более читаемой. Больше об именовании читайте в этой статье.

Работает она по такому алгоритму:

  1. С помощью ВПР попытаемся найти нужных людей в таблице с ораторами. Функция вернёт фамилию, если найдёт её в списке, или ошибку #Н/Д – в случае неудачи. Этот результат передаётся на обработку функции ЕНД;
  2. ЕНД проверяет полученное значение и возвращает ЛОЖЬ, если это фамилия, ИСТИНА – если ошибка. Результат вычисления передается функции ЕСЛИ
  3. Функция ЕСЛИ выведет в ячейку «Не участвует», если получила ИСТИНУ, или «Участвует», если ЛОЖЬ
  4. Дополнительно я оформил результаты с помощью условного форматирования. Участники будут отражены в зелёных тонах, а «прогульщики» — в красных (см. рис.)

Вот и всё, результат получен и оформлен. Кроме описанной функции, вы можете обрабатывать ошибку #Н/Д с помощью функции ЕСНД, функционал которой немного богаче.