logo

Блог Александра Томма

О том, как заставить Microsoft Office работать на Вас

Как сделать зависимый выпадающий список в Excel

Дата: 21 ноября 2018 Категория: Excel
Поделиться, добавить в закладки или распечатать статью

Здравствуйте, друзья. Когда Вы заполняете таблицы данными, перечень которых определен заранее, было бы удобно не писать их вручную, а выбирать мышью из выпадающего списка. Такой подход экономит время и минимизирует вероятность ошибки.

Приведу пример. Вы занимаетесь учетом расходов офиса, связанных с его хозяйственной деятельностью. Ваша таблица выглядит так:

Сейчас Вы вносите категории и виды расходов вручную. А значит, можете случайно ошибиться в написании. Вроде бы, ничего страшного, но если потом придется оценивать расходы с помощью сводной таблицы, ошибки исказят результат, придется исправлять.

Подробнее о сводных таблицах читайте в этой статье.

Создание раскрывающегося списка

Давайте построим перечни категорий и видов расходов, чтобы на их основании сделать выпадающие списки. Вынесем их в отдельную таблицу.

Теперь воспользуемся инструментом Проверка данных, чтобы сделать выбор из списка. Как это работает, я описывал здесь. Действуем по алгоритму:

  1. Выделяем ячейки, куда будем вносить категории
  2. Жмем на ленте Данные – Работа с данными – Проверка данных
  3. Тип данных указываем «Список», Источник – =$I$4:$I$6. То есть ссылка на наш массив с категориями. Жмем Ок
  4. Аналогично поступаем с видами расходов, повторяем пункты 1-3

Теперь Вы сможете выбрать нужные пункты из раскрывающегося списка и не ошибетесь с написанием.

Правда, остались нюансы. Мы не контролируем соответствие выбранной категории и вида расходов. Например, можно выбрать категорию «Канцелярия» и вид – «Кофе». Этого нельзя допускать. Усовершенствуем проверку данных, сделаем списки, зависимые от значения другой ячейки.

Создание зависимого списка в Экселе

Задача: когда мы выбираем категорию – в списке видов расходов должны быть лишь те, которые относятся к этой категории. Решение может показаться сложным, но это не так. Я постараюсь пояснить его максимально просто.

Cтруктурируем нашу таблицу видов расходов:

Теперь виды расходов разбиты по колонкам, соответствующим каждой из категорий. Далее мы будем использовать функцию ДВССЫЛ(текст). Что она делает? Она пытается преобразовать введенный текст в ссылку на ячейки. Что будет, если записать такую формулу: =СУММ(ДВССЫЛ(«F1:F5»)). Функция ДВССЫЛ распознает текст «F1:F5», как диапазон ячеек и вернет его. А функция СУММ – просуммирует все значения в этом диапазоне.

То же самое произойдет, если мы диапазону «F1:F5» присвоим имя. Например, «структура». Формула =СУММ(ДВССЫЛ(«структура»)) даст аналогичный результат. Именно этой возможностью мы и воспользуемся.

Чтобы больше узнать об именовании ячеек, прочтите эту статью. Рекомендую это сделать, имена – удобный и практичный инструмент.

Дадим имена всем столбцам с исходными данными. При этом, диапазон с видами должен именоваться точно так же, как и его категория. Например, диапазону J4:J8 дадим имя «Канцелярия». Именуем:

  1. Выделяем ячейки с категориями I4:I6
  2. В области имен запишем «Категории», жмем Enter
  3. Выделяем J4:J8 и называем «Канцелярия»
  4. Аналогично именуем «Хозматериалы» и «Питание»

Теперь, если кликнуть Формулы – Определенные имена – Диспетчер имен – можно увидеть все заданные имена. Если Вы где-то ошиблись, или список изменился, в этом окне можно внести исправления.

Еще раз настраиваем проверку данных:

  1. Выделяем в таблице столбец с категориями
  2. Жмем на ленте Данные – Работа с данными – Проверка данных
  3. Тип данных указываем «Список», Источник – =Категории. Программа определит, что это именованный диапазон и выберет из него пункты списка. Жмем Ок
  4. Выделяем столбец с видами расходов
  5. Тип данных указываем «Список», Источник – =ДВССЫЛ(B4). Вместо B4 подставится название выбранной категории. Это название совпадает с именем диапазона, в котором хранятся расходы данной категории. Функция ДВССЫЛ преобразует это имя в диапазон, а Excel извлечет из этого диапазона пункты.
  6. Жмем Ок, теперь все работает

Если все еще не понятен принцип, опишу по пунктам, как теперь будет работать наша таблица:

  • С помощью обычного списка, в столбце B выбираем категорию товаров. Например, «Питание»
  • Слово «Питание» попадает, как источник данных в столбец C, т.е. в виды расходов
  • У нас есть диапазон данных L4:L8, который называется Питание. Функция ДВССЫЛ это определяет и заменяет на слово «Питание» на диапазон L4:L8
  • Теперь этот диапазон будет источником для списка вида расходов

Все перечисленное подтверждаю изображением ниже:

Как видите, список видов расходов заполнился не всем перечнем, а только теми пунктами, которые принадлежат выбранной категории «Питание». Именно этого мы и добивались.

Думаю, Вы разобрались, как сделать зависимый список в Excel. Если не разобрались – пишите комментарии. А я статью закончил, продуктивной Вам работы!

Поделиться, добавить в закладки или распечатать статью

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *